Back to overview
Degraded
iTrent, Stonefish, Person Finder Slow / Unavailable
Jun 5, 2025 at 10:37am UTC
Affected services
iTrent
Software
Resolved
Jun 5, 2025 at 12:32pm UTC
This issue has now been resolved.
Affected services
Created
Jun 5, 2025 at 10:37am UTC
We are aware of issues with the above services and are investigating.
Affected services