Student Accommodation Portal - Technical Issue
Resolved
Jun 27 at 08:35am BST
We believe that the performance issues with Room Service are now resolved. The vendor, Kinetic are continuing to work on identifying the root cause and Application Support are continuing to monitor telemetry for changes in system performance.
Affected services
Other
Created
Jun 26 at 08:30am BST
Our Residence Life team have informed us of a technical issue that is affecting the Student Accommodation Portal, and have provided the following message:
We are aware of the ongoing technical issues affecting the university's accommodation application system. Our internal IT team, along with our external system provider, is actively working to resolve the problem as quickly as possible. We sincerely apologise for the inconvenience this may be causing and appreciate your patience during this time.
We also understand the concern surrounding the advertised application deadline of 01 July 2025. Please be assured that any student unable to complete their application due to these technical difficulties will not be disadvantaged in the accommodation allocation process. The university is currently reviewing how best to manage the situation, and further communication will be shared with all affected applicants in due course.
Affected services
Other