Back to overview
Degraded
Agresso - Intermittent Authentication Issues
Jul 04 at 10:50am BST
Affected services
Business World (Agresso)
Updated
Jul 08 at 08:00am BST
Our technical teams are continuing to investigate the intermittent authentication issues affecting Agresso. We appreciate your patience and will provide further updates as soon as we have more information.
Affected services
Business World (Agresso)
Created
Jul 04 at 10:50am BST
We are investigating an intermittent issue affecting signing in to Business World (Agresso).
Please try signing in again, or close and re-open your browser, as it should then allow you to access Agresso normally.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services
Business World (Agresso)