Back to overview
Degraded
Outlook/Teams - Calendar Availability Issue
Jul 7, 2025 at 2:15pm UTC
Affected services
Email and Calendar
Resolved
Jul 8, 2025 at 10:45am UTC
This issue is now resolved.
Affected services
Created
Jul 7, 2025 at 2:15pm UTC
According to Microsoft: “Some users may be unable to see Free/Busy information for other users within their organization”.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services