Back to overview
Degraded
Printing (PaperCut, UPS1, UPS2) - Potential Issues
Aug 21 at 09:50am BST
Affected services
University Print Service
Resolved
Aug 21 at 11:30am BST
This issue has been resolved.
Affected services
Created
Aug 21 at 09:50am BST
We are investigating a potential issue affecting printing.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services