Back to overview
Degraded
TOPdesk - Search Functionality (for Operators)
Sep 24 at 09:05am BST
Affected services
Self-Service Portal (TOPdesk)
Resolved
Sep 25 at 09:00am BST
This issue is now resolved.
Affected services
Created
Sep 24 at 09:05am BST
We are investigating an issue affecting TOPdesk's search functionality (for Operators).
The issue affects the search functionality only. You can still open tickets by entering "I25-XXXXXXX" into the search field and hitting the search button.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services