Back to overview
Degraded
Authentication - Performance Issues
Sep 30 at 11:00am BST
Affected services
Accounts and Passwords
Resolved
Sep 30 at 05:30pm BST
This issue appears to have stabilised and is considered resolved.
Affected services
Created
Sep 30 at 11:00am BST
We are currently experiencing heavy demand on our authentication servers due to the start of the new academic year. As a result, some users may encounter timeouts or error messages when signing in to services. If this happens, please refresh the page or try again after a short while.
Affected services