Back to overview
Degraded

Microsoft Office 365 - Applications Not Opening

Oct 08 at 10:30am BST
Affected services
Software

Updated
Oct 10 at 10:30am BST

We are continuing to monitor this incident. The previously detailed fix has resolved the issue for the majority of users (over 95%).

Updated
Oct 08 at 11:20am BST

We’ve identified that performing an Online Repair¹ of Microsoft Office, followed by a restart of your device, resolves the issue.

¹ The 'Online Repair' option must be selected. Other options may not work.

Please follow the steps above, as this should resolve the issue. There is no need to respond if your issue has been fixed. However, if the problem persists after completing these steps, please reply to your original ticket to let us know.

Updated
Oct 08 at 11:00am BST

As a workaround, affected users can temporarily use the online versions of the Microsoft 365 applications by visiting https://m365.cloud.microsoft/apps/.

We understand this is not ideal for all users and want to assure you that resolving this issue is our top priority.

Created
Oct 08 at 10:30am BST

We are investigating a potential issue affecting Microsoft 365 applications, where one or more apps may fail to load or display an error message.

We will provide further updates as soon as possible, and apologise for any inconvenience caused.