Back to overview
Degraded
Microsoft Power Automate - Potential Issues
Nov 20, 2025 at 11:45am UTC
Affected services
Other
Resolved
Nov 20, 2025 at 3:00pm UTC
This issue is now resolved.
Affected services
Created
Nov 20, 2025 at 11:45am UTC
There are reports of issues affecting the external Microsoft Power Automate service.
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services