Back to overview
Degraded

iTrent - Unable to Print Payslips

Dec 4, 2025 at 4:38pm UTC
Affected services
iTrent

Resolved
Dec 9, 2025 at 9:00am UTC

This issue is now resolved.

Created
Dec 4, 2025 at 4:38pm UTC

Printing of payslips through iTrent is currently unavailable and will result in an error message being displayed. We are aware of the problem and are working with the suppliers to resolve.