Back to overview
Degraded

TOPdesk - Email Issue/Error

Jan 06 at 11:45am GMT
Affected services
Self-Service Portal (TOPdesk)

Resolved
Jan 06 at 12:30pm GMT

This issue is now resolved.

Updated
Jan 06 at 11:55am GMT

This issue now appears to be resolved. We will continue to monitor the service.

Created
Jan 06 at 11:45am GMT

We are investigating an issue affecting TOPdesk's email functionality,

We will provide further updates as soon as possible, and apologise for any inconvenience caused.