Worktribe - Intermittent Authentication Issues
Resolved
Jan 30, 2026 at 09:00am UTC
This issue is now resolved.
Affected services
Updated
Jan 29, 2026 at 05:20pm UTC
Our supplier has provided the following update: "We understand that some clients are continuing to experience downtime on your Worktribe systems. We apologise that this continues to be an issue for some of you - the problem is with DNSSEC - but please be reassured that we are still working on this as a priority."
Affected services
Created
Jan 29, 2026 at 10:05am UTC
We’re aware of a potential issue affecting a small number of users when logging in to Worktribe. Clearing your browser cache and DNS cache should resolve the issue. We are monitoring the situation and will provide updates if needed.
Affected services