Back to overview
Degraded
KxWelcome - Database Issue
Jan 30, 2026 at 11:35am UTC
Affected services
Other
Resolved
Jan 30, 2026 at 11:45am UTC
KxWelcome is now available again. We’ll continue to investigate the cause of the issue, but will mark this status as resolved.
Affected services
Created
Jan 30, 2026 at 11:35am UTC
We are investigating an issue affecting KxWelcome (Room Service).
We will provide further updates as soon as possible, and apologise for any inconvenience caused.
Affected services