Back to overview
Degraded

Project Mapper - Unavailable

Feb 10 at 12:45pm GMT
Affected services
Other

Resolved
Feb 10 at 12:52pm GMT

This issue is now resolved.

Created
Feb 10 at 12:45pm GMT

We are investigating an issue affecting Project Mapper.

We will provide further updates as soon as possible and apologise for any inconvenience caused.