Back to overview
Degraded
Network - Potential DNS Services Issue
Feb 16, 2026 at 2:23pm UTC
Affected services
Accounts and Passwords
Resolved
Feb 16, 2026 at 3:00pm UTC
This issue is now resolved.
Affected services
Updated
Feb 16, 2026 at 2:35pm UTC
Service appears to be returning to normal. We will continue monitoring the situation.
Affected services
Created
Feb 16, 2026 at 2:23pm UTC
We are investigating an issue affecting our Network DNS Services.
We will provide further updates as soon as possible and apologise for any inconvenience caused.
Affected services