Back to overview
Degraded

Network - No Internet or Wi-Fi Service in Eastwood 51

Mar 9, 2026 at 11:12am UTC
Affected services
Network (Ethernet & Wi-Fi)

Resolved
Mar 11, 2026 at 12:15pm UTC

This issue is now resolved.

Created
Mar 9, 2026 at 11:12am UTC

As a result of a power cut there is currently no internet or Wi-Fi service in Eastwood 51, Campus Infrastructure are investigating.