Back to overview
Degraded

iTrent – Access Issue (Affecting New Accounts)

Apr 8, 2026 at 10:40am UTC
Affected services
iTrent

Resolved
Apr 9, 2026 at 9:50am UTC

This issue has now been successfully resolved. The change to load new account details into iTrent was implemented yesterday, and the overnight process completed successfully. All accounts that failed to be created over the past few days have now been added and should be working as expected.

Created
Apr 8, 2026 at 10:40am UTC

A small number of users with new accounts created since 1 April are currently unable to access iTrent Employee Self Service (ESS) and Manager Self Service (MSS).

Our HR & Payroll team have identified the issue and are actively working on a fix. We expect access to be fully restored by 09:00 on 9 April.

We apologise for any inconvenience caused and will provide updates if there are any changes.