Back to overview
Degraded

SAMIS - Caching Issue

Apr 16, 2026 at 9:10am UTC
Affected services
SAMIS

Resolved
Apr 16, 2026 at 11:00am UTC

We believe that this issue is now resolved. Any residual issues may be caused by local browser caching, where an older version of the SAMIS web files is being stored on your device.

In many cases, this can be resolved by performing a hard refresh:

  • Chrome / Edge (Windows): Ctrl + Shift + R
  • Chrome / Edge (Mac): Cmd + Shift + R

If the issue persists, please follow the steps below to fully clear your browser’s cache and cookies.


How to Clear Your Browser Cache

Google Chrome

  1. Click the three dots menu (top‑right) → Settings
  2. Select Privacy and security
  3. Click Clear browsing data
  4. Set Time range to All time
  5. Tick:
    • ✅ Cookies and other site data
    • ✅ Cached images and files
  6. Click Clear data
  7. Close and reopen Chrome, then try SAMIS again

Microsoft Edge

  1. Click the three dots menu → Settings
  2. Choose Privacy, search and services
  3. Under Clear browsing data, click Choose what to clear
  4. Set Time range to All time
  5. Tick:
    • ✅ Cookies and other site data
    • ✅ Cached images and files
  6. Click Clear now
  7. Restart Edge and revisit SAMIS

Mozilla Firefox

  1. Click the three lines menu → Settings
  2. Go to Privacy & Security
  3. Under Cookies and Site Data, click Clear Data
  4. Tick:
    • ✅ Cookies and Site Data
    • ✅ Cached Web Content
  5. Click Clear
  6. Restart Firefox

Safari (macOS)

  1. Open Safari → Settings
  2. Go to Privacy
  3. Click Manage Website Data
  4. Select Remove All
  5. Close and reopen Safari

If issues continue after clearing your cache, please contact IT Support and include:

  • Your browser and version
  • The page you were accessing
  • A screenshot (if possible)

Further updates will be provided if required.

Created
Apr 16, 2026 at 9:10am UTC

Some users may be seeing outdated pages or display issues when using SAMIS.

This is due to cached files not yet updating consistently across all servers that support the service. We are investigating the issue and working to ensure the latest version is correctly applied everywhere.

The core functionality of SAMIS is not affected, and we will provide an update as soon as the issue is resolved.